AppSuite

AppSuite(アップスイート)は、紙・メール・Excel主体で行われている非効率な社内業務を、たった4ステップで社内システム化できる、社内システム構築ツールです。
台帳管理の効率化から、複雑な業務処理のシステム化まで。
AppSuiteが、あなたの会社をもっと働きやすい環境に変えていきます。

※この機能を使用するためにはライセンスの購入が必要です。

印刷ボタン

アプリケーション一覧を表示する


自分が利用できるアプリケーションの一覧が表示されます。




アプリケーション一覧
アプリケーションの一覧です。(下記詳細)





データ一覧を表示する


アプリケーション一覧画面でアプリケーション名リンクを押して、ブラウズ画面に移動します。





データの詳細を表示する


ブラウズ画面(一覧表示)の詳細アイコンを押すと、該当するデータの詳細画面が表示されます。





短縮URLを使用する


共有アイコンを押すと、短縮URLを使用できます。
短縮URLは参照している画面のURLを短縮することで、ネオツイのつぶやきなど文字数制限がある投稿などにご利用頂けます。




発行した短縮URLは、ネオツイの短縮URL一覧からも確認することができます。
(詳しくは、ユーザーズマニュアルの ネオツイ の説明をご覧ください。)


データを追加する


[新規追加]ボタンを押すと、データの新規追加画面が表示されます。
※この操作にはアクセス権が必要です。アプリケーション管理者が権限を付与できます。




他のアプリケーションからデータを入力する
キー部品の虫眼鏡アイコンからデータ選択ダイアログを表示して他のアプリケーションの複写部品、参照部品にデータを入力します。



選んだデータが関係付けられたキー部品、複写部品、参照部品に入力されます。



すべての入力が完了したら、[追加]ボタンを押してデータを保存してください。


データを変更する


以下のいずれかの方法で、登録済みのデータを変更することができます。


■1件ずつ変更する

データの詳細を表示した画面で[編集]ボタンを押すと、データ変更画面が表示されます。
※この操作にはアクセス権が必要です。アプリケーション管理者が権限を付与できます。



変更が完了したら、[変更]ボタンを押してデータを保存してください。


■複数件まとめて変更する


一覧画面で[その他の機能]メニューの「表示中のデータを一括編集」を押すと一括でデータを変更することができます。
※この操作にはアクセス権が必要です。アプリケーション管理者が権限を付与できます。

[その他の機能]ボタンから「表示中のデータを一括編集」メニューを選択


一括変更画面




■ダブルクリックしたセルのデータだけ変更する

一覧画面のデータが表示されているセルでダブルクリックをすると、データを変更することができます。
※この操作にはアクセス権が必要です。アプリケーション管理者が権限を付与できます。




入力欄からフォーカスが外れるとデータを保存します。


■複数件まとめて置換する


一覧画面で[その他の機能]メニューの「値の置換」を押すと値の置換ダイアログが表示されます。
部品毎に一括でデータを置換することができます。
※この操作にはアクセス権が必要です。アプリケーション管理者が権限を付与できます。

[その他の機能]ボタンから「値の置換」メニューを選択


値の置換ダイアログ(1/2)



対象部品を選択すると、置換内容の入力欄が表示されます。

値の置換ダイアログ(2/2)



[OK]ボタンを押すと、確認ダイアログが表示されます。
確認ダイアログの"置換する"にチェックを付けて[はい]ボタンを押すと、置換が開始されます。
置換が完了すると、値の置換完了ダイアログが表示されます。
※置換に失敗したデータがある場合、値の置換完了ダイアログにログファイルをダウンロードするリンクが表示されます。


データを削除する


一覧画面、詳細画面、変更画面の[削除]ボタンを押すと削除確認ダイアログが表示されます。
削除確認ダイアログの[はい]ボタンを押すと、該当のデータが削除されます。削除されたデータは復活できません。十分ご注意ください。

一覧のデータをすべて削除


[その他の機能]ボタンを押して表示されるメニューの「一覧のデータをすべて削除」を押すと、削除確認ダイアログが表示されます。
削除確認ダイアログの"削除する"にチェックを付けて[はい]ボタンを押すと、一覧のデータがすべて削除されます。削除されたデータは復活できません。十分ご注意ください。


データを絞り込む


表示するデータを絞り込む機能です。
リンクを押すと絞り込み条件ダイアログが表示されます。




[検索]ボタンを押すと入力した検索条件に該当するデータを一覧に表示します。


絞り込み条件ダイアログ(詳細検索)
詳細検索では、すべての部品を検索対象として設定することができます。




[検索]ボタンを押すと入力した検索条件に該当するデータを一覧に表示します。


お気に入り検索条件を管理する


表示中の画面の状態をお気に入り検索条件として登録しておき、あとで再表示することができる便利な機能です。
画面、絞込み、キーワード検索、並び順の4つの状態が保存されます。




お気に入り検索条件の管理ダイアログ




データをファイルに保存(エクスポート)する


[その他の機能]ボタンを押して表示されるメニューの「CSVファイルへエクスポート」を押すと、CSVファイルへエクスポートダイアログが表示されます。
登録されているデータをファイルに保存することができます。

CSVファイルへエクスポート (1/2)



[次へ>]ボタンを押すと、出力する部品の設定画面が表示されます。


CSVファイルへエクスポート (2/2)



すべての入力が完了したあとで、[エクスポート]ボタンを押すとCSVエクスポート完了ダイアログが表示されます。
CSVエクスポート完了ダイアログのダウンロードリンクを押すとCSVファイルを保存することができます。


データをファイルから一括登録(インポート)する


[その他の機能]ボタンを押して表示されるメニューの「CSVファイルからインポート」を押すと、CSVファイルからインポートダイアログが表示されます。
データをファイルから一括登録できます。

CSVファイルからインポート (1/2)



[次へ>]ボタンを押すと、一括登録する部品の設定画面が表示されます。


CSVファイルからインポート (2/2)



すべての入力が完了したあとで、[インポート]ボタンを押すと確認ダイアログが表示されます。
確認ダイアログの[はい]ボタンを押すと、インポートが開始されます。
インポートが完了すると、CSVインポート完了ダイアログが表示されます。
※インポートに失敗すると、その時点でインポートが中断されます。CSVファイルよりエラーが発生した行以前を削除してから、インポートをやり直してください。


集計結果を表示する


集計メニューから閲覧したい集計を選択し、集計結果画面を表示します。
※集計が作成されていない場合メニューには「集計設定」のみ表示されます。




集計結果画面




画面構成と基本操作


アプリケーションのデータを集計し、グラフで表示することができます。




集計ツールバー(新規)



集計ツールバー(変更)




集計方法パネル


集計の方法を編集できるパネルです。
項目一覧、デザインなどはグラフの種類によって設定する内容が変わります。



集計設定を追加する


集計メニューの「集計設定」を押すと、新規の集計設定画面が表示されます。



集計設定画面



グラフ名 集計例 特徴
クロス集計
2つ以上の項目を抽出してデータ分析・集計を行う手法です。
縦棒グラフ
各項目の集計値の大小を比較します。
時系列の変化を表すこともできます。
積み上げ縦棒グラフ
各項目の集計値の合計を比較します。
時系列の変化を表すこともできます。
100%積み上げ縦棒グラフ
各項目の集計値の割合を比較します。
時系列の変化を表すこともできます。
横棒グラフ
各項目の集計値の大小を比較します。
時系列の変化を表すこともできます。
積み上げ横棒グラフ
各項目の集計値の合計を比較します。
時系列の変化を表すこともできます。
100%積み上げ横棒グラフ
各項目の集計値の割合を比較します。
時系列の変化を表すこともできます。
折れ線グラフ
時系列で集計値の変化を表現ことに適しています。
面グラフ
折れ線グラフに色を塗ったグラフです。
積み上げ面グラフ
面グラフの各集計値の合計を示すグラフです。
100%積み上げ面グラフ
面グラフの各集計値の割合を示すグラフです。
円グラフ
全体に対する各項目の割合を示すグラフです。
ゲージ
集計値の達成率を示すグラフです。
カード
集計結果のみを強調表示します。

入力が完了したあとで、[保存]ボタンを押すと公開設定ダイアログが表示されます。


公開設定ダイアログ



すべての入力が完了したら、[保存]ボタンを押してデータを保存してください。


クロス集計を作成する


クロス集計とは、2つ以上の項目を抽出してデータ分析・集計を行う手法です。



集計方法:項目一覧



行、列の部品設定
行と、列の部品に対して設定を行うことができます。
部品名のリンクを押すと、設定ダイアログが表示されます。




すべての入力が完了したら、[OK]ボタンを押してデータを保存してください。


集計値の設定
集計値の部品に対して設定を行うことができます。
部品名のリンクを押すと、設定ダイアログが表示されます。




すべての入力が完了したら、[OK]ボタンを押してデータを保存してください。


集計方法:デザイン(レイアウト)



集計方法:デザイン(スタイル)



集計方法:タイトル




棒グラフ・折れ線グラフ・面グラフを作成する


凡例、軸、集計値からデータを視覚的にわかりやすく表します。



集計方法:項目一覧



軸(項目)、凡例(系統)の設定
軸(項目)と、凡例(系統)の部品に対して設定を行うことができます。
部品名のリンクを押すと、設定ダイアログが表示されます。




すべての入力が完了したら、[OK]ボタンを押してデータを保存してください。


集計値の設定
集計値の部品に対して設定を行うことができます。
部品名のリンクを押すと、設定ダイアログが表示されます。




すべての入力が完了したら、[OK]ボタンを押してデータを保存してください。


集計方法:デザイン(レイアウト)



集計方法:デザイン(スタイル)



集計方法:タイトル




円グラフを作成する


軸、集計値から丸い図形を扇形に分割し、データの内訳や構成比率を表します。
※集計値にマイナスが含まれるとグラフは表示されません。
※円グラフは集計値の降順で並び替えられます。



集計方法:項目一覧



軸(項目)の設定
軸(項目)の部品に対して設定を行うことができます。
部品名のリンクを押すと、設定ダイアログが表示されます。




すべての入力が完了したら、[OK]ボタンを押してデータを保存してください。


集計値の設定
集計値の部品に対して設定を行うことができます。
部品名のリンクを押すと、設定ダイアログが表示されます。




すべての入力が完了したら、[OK]ボタンを押してデータを保存してください。


集計方法:デザイン(レイアウト)



集計方法:デザイン(スタイル)



集計方法:タイトル




ゲージグラフを作成する


決まった範囲で測定可能な値をゲージに模した形で表現するグラフです。



集計方法:項目一覧



集計値の設定
集計値の部品に対して設定を行うことができます。
部品名のリンクを押すと、設定ダイアログが表示されます。




すべての入力が完了したら、[OK]ボタンを押してデータを保存してください。


集計方法:デザイン(レイアウト)



集計方法:デザイン(スタイル)



集計方法:タイトル




カードを作成する


集計結果をカードに模した形で表現します。



集計方法:項目一覧



集計値の設定
集計値の部品に対して設定を行うことができます。
部品名のリンクを押すと、設定ダイアログが表示されます。




すべての入力が完了したら、[OK]ボタンを押してデータを保存してください。


集計方法:デザイン(レイアウト)



集計方法:デザイン(スタイル)



集計方法:タイトル




集計設定を変更する


集計設定の集計ツールバーから集計を選択すると、集計の変更画面が表示されます。



変更が完了したら、[変更]ボタンを押してデータを保存してください。


集計設定を別名で保存する


[変更]ボタンの右にある[▼]アイコンを押して表示されるメニューから「名前をつけて保存」を押すと名前をつけて保存ダイアログが表示されます。



名前をつけて保存ダイアログ



すべての入力が完了したら、[保存]ボタンを押してデータを保存してください。


集計設定を削除する


[変更]ボタンの右にある[▼]アイコンを押して表示されるメニューから「削除」を押すと削除確認ダイアログが表示されます。
削除確認ダイアログの[はい]ボタンを押すと、該当の集計設定が削除されます。削除された集計設定は復活できません。十分ご注意ください。
※集計設定を削除した場合、作成されていた集計結果も削除されます。十分ご注意ください。




集計管理


集計設定画面のオプションメニューで「集計管理」を押し、集計管理ダイアログを表示します。




集計設定オプション:公開設定




集計設定オプション:定期集計設定
※「定期集計」をご利用いただく場合は、desknet's NEOのスケジューラーが起動している必要があります。




集計設定オプション:集計結果設定



すべての設定が終わったら、[変更]ボタンを押してデータを保存してください。


定期集計結果ログ


集計設定画面のオプションメニューで「定期集計結果ログ」を押し、定期集計結果ログダイアログを表示します。